2016-03-10

Cómo usar BUSCARV y SUMAR conjuntamente en Excel

Title

Problema

Tenemos el siguiente rango de datos y queremos devolver la suma de varios meses.

Soluciones

  • Utilizamos BUSCARV como fórmula matricial. En el indicador de columnas en lugar de especificar una única columna, especificamos entre corchetes el número de columnas deseado. Por ejemplo, enero, febrero, abril y diciembre {2;3;5;13}.
  • Anidamos BUSCARV dentro de SUMA y presionamos, al ser una fórmula matricial, Ctrl+Mayús+Entrar.
  • {=SUMA(BUSCARV(O2;$A$1:$M$4;{2;3;5;13};0))}
    
  • La fórmula SUMA, sumará la matriz obtenida con BUSCARV —77, 82, 84 y 59— arrojando un resultado de 302.

Notas

Además de la función SUMAR, podemos realizar otros cálculos como mínimos, máximos, promedios, etc.

15 comentarios:

  1. hice la formula tal y como esta en el ejemplo y no me deja, me muestra una ventana donde me dice que hay un problema con la formula

    ResponderEliminar
    Respuestas
    1. Algo no debes de haber hecho de igual manera para obtener dicho error. Plantea tu duda en un foro de Excel con más detalles. Saludos.

      Eliminar
    2. creo que el error me lo muestra por los corchetes que estan al inicio y al final de la formula...

      Eliminar
    3. Es una fórmula matricial. Está indicado en la entrada. Los corchetes son colocados automáticamente por Excel si sigues bien las instrucciones. Hay que leer con atención antes de preguntar.

      Eliminar
    4. lo que tienes que hacer es terminar la formula y una vez que la termines en la celda presiona F2 y despues Ctrl+Mayús+Entrar y esta listo

      Eliminar
    5. Pues sigue sin funcionar, hay que habilitar algo?

      Eliminar
    6. No, lo que hay que hacer es introducir la fórmula matricial correctamente. Está explicado en la entrada, en los comentarios. Trataré de explicarlo con más claridad y detalle, pues parece suscitar muchas preguntas. Gracias.

      Eliminar
  2. Hola, ejecuto la fórmula y no me hace la suma de las diferentes columnas, solo me devuelve el valor de la primera columna, por qué puede ser?

    ResponderEliminar
    Respuestas
    1. Lee con atención la entrada o pregunta en un foro de Excel describiendo el error con mayor detalle. Saludos.

      Eliminar
  3. A mi me pasa lo mismo, no da errores pero tampoco me da la suma, sólo el valor de la primera columna.

    ResponderEliminar
    Respuestas
    1. Porque no introduces las fórmula matricial correctamente. Estás explicado en la entrada y en los comentarios.

      Eliminar
  4. Hola, pretendo realizar la búsqueda en diferentes hojas y la suma de una sola columna (todas en la misma), se supone que la sintaxis queda así: {=SUMA(BUSCARV($B3,'Ago:Oct-Nov'!B4:AC33,{3,3,3,3},0))} pero me da error de #¡VALOR!
    También intente con: {=SUMA(BUSCARV($B3,'Ago:Oct-Nov'!B4:AC33,{3},0))}

    ResponderEliminar
    Respuestas
    1. Hola Carlos, esta sintaxis no funciona para hoja múltiples. Habría que resolverlo de manera diferente. Tal vez cree una entrada próximamente al respecto. Saludos.

      Eliminar
  5. Muy agradecido por la informacion, pero digamos si la informacion lo tuvierammos de manera vertical? Como variaria la formula?

    ResponderEliminar
    Respuestas
    1. Si lo que necesitas es buscar el nombre de las columnas y devolver la suma de varias filas, exactamente misma sintaxis pero con BUSCARH =SUMA(BUSCARH(O2;$A$1:$M$4;{2;3;5;13};0)), recuerda presionar Ctrl+Mayús+Entrar.

      Eliminar

Nube de datos